How do change my file extensions to original and see them again?

Question

Last night I was trying to open programs like bitmap & jpg files using Mircosoft Imager & it wouldn't recognize the file extension so it gave me error. I said "OK" then exited the

program, now this morning I see all the files have a extension of Microsoft Imager 1.0 Picture & nothing opens. Is there a way to rename the extensions back to the original names to recover???, plus everything that I now scan in becomes a Microsoft Imager 1.0 Picture extension, what is going on & what can I do to solve this problem. If I scan stuff now it's useless.

HELP in gilbert

Dave Peterson

Answer

This question was answered on June 30, 1999. Much of the information contained herein may have changed since posting.

The Windows operating system identifies files by their file extension The file extension is the three letters that follow the period in a file's name For example "myletter.doc" is a word processing file identified by the .doc extension, "BudgetSpreadsheet.xlx" is a Microsoft Excel spreadsheet identified by the .xls extension, and "SomePicture.jpg" is a JPEG file identified by the .jpg extension When you open a file by double clicking on it, the Windows operating system checks the file extension It uses that information to determine which program to use open up that file The relationship between the file extension and the program used to open it is called a File Association.

What this means is that the files have changed their extensions and cannot be accessed any more because they are not with the right extensions so they cannot be opened, as the software which opens the file does not see any You can change this by:

First open Explorer To do this find the icon named My Computer on your desktop ( this is assuming that you haven't changed the name of MyComputer to something else ) Right click on the icon and select "Explore" from the pop-up menu A window with the title "Exploring" will open To make it easier to identify files extensions, click on "View" at the top of the "Exploring" window and select "Options" In the "Options" window that opens, uncheck the box beside the words "Hide MS-DOS file extensions for file types that are registered" by clicking in the box (If there isn't a check in the box than do nothing) Click on OK Go to a folder that contains the file you want to open Now hold down the "Shift" key and right click on the file you want to open In the pop-up menu select "Open with" This will open a window called "Open With" Use the scroll bar to scroll down until you see the program you wish to use to open this file and select it with the mouse If you want to change the File Association so that this program will always open up this type of file (i.e., .jpg extensions), check the box beside "Always use this program to open this type of file" and click on the OK button If you leave the box unchecked, then only in this instance will the file be opened by the program you selected.

p.s If you don't usually like to see the file extensions when using "Explorer" just go back to "View" - "Options" and check the "Hide MS-DOS file extensions..." box again

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Ken of Data Doctors on June 30, 1999