How do I change MinSPS settings in system.ini?

Question

I am running Windows ME. I just downloaded and installed the "Critical Updates" package from Microsoft. When I was asked if I wanted to restart Windows, I responded "yes". During the restart, the infamous blue window appeared with the message,"A VxD, possibly recently installed, has consumed too much stack space. Increase the settings of MinSPs in system.ini or remove the recently installed VxDs. There are currently 5 SPs allocated." When I closed the error window, the restart appeared to complete normally, and the system is running. I can't find a MinSP parameter in the windows system.ini file.

Is this a problem I need to be concerned about, ie. will it bite me sometime when I'm least expecting it? If so how do I fix it?

Thank you very much

Answer

This question was answered on December 7, 2000. Much of the information contained herein may have changed since posting.

Hello and thank you for sending your question.

I am giving you two options of doing this:

First, open up the system.ini file in a text editor and go to the [386Enh] section Add the line:

[386Enh]

MinSPS=9

(Default is 2, however, you can go to 6 if needed) Adding MinSPS=9 to the system.ini will give you a total of 9 usable stacks Microsoft also recommends incrementing it by 4.

Second,if you have a startup disk, boot off of it Type the follwing and hit enter after each line:

C:

cd\windows

edit system.ini

Find the Min...line, make your changes and save the file Restart your computer without the boot disk.

I hope this helps you with your situation, if not, please, resubmit.

Good luck,

LREVERT

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Leonida of Chandler-Gilbert Community College on December 7, 2000