Why my PC can't see my Iomega parallel port Zip drive?

Question

Description of problem: My AMD k-6 computer will not see my Iomega parallel port zip drive. I can take the zip drive and connect it to my old 486 with no problems but not my brand new computer. It has an Aopen motherboard. I have downloaded and installed the latest drivers but it still tells me the device is not present or that newer drivers should be installed.

Answer

This question was answered on January 26, 2001. Much of the information contained herein may have changed since posting.

It sounds like you need to check the parallel port mode in the computer setup (BIOS) The port may not be enabled, or the port mode may need to be changed The port mode should be set to EPP or bi-directional To access your computer setup (BIOS) refer to your computer documentation or contact the manufacturer for instructions.

Sometimes software installed with your printer or scanner can take control of the parallel port which would prevent the software from communicating with your Zip drive You can refer to http://www.iomega.com/support/documents/10392.html

Also if you are trying to use your Zip drive on LPT2 I recommend that you try it on LPT1 If it works like this then leave it connected to LPT1 and connect your other devices, printer or scanner to LPT2.

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Lanny of Chandler-Gilbert Community College on January 26, 2001