The "why won't Defrag run..." question!

Question

I read a tip regarding starting your computer in safe mode to allow a full drive defrag. I tried this and it worked. My problem now is that my computer looks like it is in safe mode all the time, although I don't think it is because when I bring up Windows Startup Menu, it shows it in normal mode. What have I done and how can I correct it?

Answer

This question was answered on August 27, 2001. Much of the information contained herein may have changed since posting.

Question concerning the 'Defrag' utility are one of the most common to our weekly radio show, so I will start by covering the basics.

The Windows defrag utility can improve system performance by restructuring fragmented files on your hard drive Because the standard operation of a computer can scatter files into various 'sectors' of your hard drive which makes it slower, it's a good idea to run defrag at least once a month.

Fragmentation of your files is like filing page one of a document in the top file drawer, page two in the second drawer, page three in the third drawer and so on The defrag utility reunites these fragments into contiguous sectors or puts them all together and into the same 'drawer' so that access times are improved.

Because the defrag process is actually moving data around on the hard drive, it must have exclusive control of the drive or data corruption can occur.

That being the case, anything that tries to access the hard drive during the defrag process will cause it to start all over again This includes screen savers, anti-virus programs or any utility that can be running in the background.

Disabling these programs prior to launching the defrag utility will generally help to reduce the possibility of restarts You can disable most programs by either right clicking on the icons in the 'Systray' (bottom right next to the clock) or by using the three-fingered salute (Ctrl-Alt-Del), which brings up the 'Close Programs' window (close everything but Explorer and Systray).

If neither of the above methods works, starting Windows in 'Safe Mode' before running

defrag will usually do the trick It basically tells the computer not to load anything unless it is absolutely essential to the basic operation of Windows, which keeps the interfering programs from loading It also loads the lowest resolution video driver, which is why it looks funny.

To start Windows 95 in Safe mode, restart your computer and then when you see the "Starting Windows 95" message, press the F5 key To start Windows 98 or ME in Safe mode press and hold down the CTRL key during the startup of the computer and choose Safe Mode from the menu.

When defrag has completed you can generally restart the computer and it will return to its original state In your case it sounds like the video driver reset itself to a default size and color depth.

Try adjusting your display properties by right clicking on the desktop and choosing properties Click on the 'Settings' tab at the top and then increase both the 'Color' and 'Screen Area' settings until it looks right again.

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Ken of Data Doctors on August 27, 2001