Recycle your Computers & Technology with us.

How to fix error message mmcndmgr.dll is not registered?

Posted By : Enyenihi of Katharine Gibbs School - New York on March 6, 2003

Follow us on Facebook   Follow us on Twitter   Follow us on LinkedIn

Let Data Doctors be your personal IT department today

Sure enjoy your show...it is terrific!!!

Here is my problem...I have started getting a message that: mmcndmgr.dll is not registered...( whatever that means )...Have not been able to correct this and hope you can tell me how to do it....

Thanks......Bob Vaught.....Prescott

This question was answered on March 6, 2003. Much of the information contained herein may have changed since posting.


Is the file on your system? Have you done a search?

It sounds like the Policy is restricting all users including the administrator

The program you need is regsvr32 yourDLL here Use it from a command prompt or the run command from the start menu.

Symptom

When attempting to launch the Zetafax configuration program it fails with a Microsoft Management Console error “MMC cannot create a node manager Make sure the file Mmcndmgr.dll is registered”.

Cause

The Microsoft Management Console (MMC) version 1.2 install, fails to register MMCNDMGR.DLL.

Resolution

The MMCNDMGR.DLL needs to be registered manually this is achieved by following the instructions below:

1 From the run command, browse to the MMCNDMGR.DLL

2 This will usually be situated in your C:\WINNT\system32 directory

3 Edit the path as follows: REGSVR32 C:\WINNT\system32\MMCNDMGR.DLL and hit OK

4 You should receive a response from REGSVR32 as follows

DllRegisterServer in C:\WINNT\sysyem32\MMCNDMGR.DLL succeeded

5 You may need to register the zetasnap.dll which is located in the zfax\SERVER folder Use the following line to register the zetasnap.dll

REGSVR32 C:\ZFAX\SERVER\zetasnap.dll

6 You should receive the following message

DllRegisterServer in C:\ZFAX\sysyem32\Zetasnap.dll succeeded

7 The Zetafax Configuration should now work as expected

If the above registration process failed, it is possible that re-running the Microsoft Management Console version 1.2 install (IMMC.EXE) may resolve this issue This program is located on the Zetafax 7 CD-ROM or available for download on the Equisys website www.equisys.com.

If neither solution above is able to resolve the issue, Zetafax may be configured using ZFSETUP.EXE in non-MMC mode by following the instructions below.

1 Edit the file zfax\SYSTEM\Z-DB\SETUP.INI (where ‘zfax’ is the name of the directory where the Zetafax files are installed) Locate the '[OPTIONS]' paragraph then add the following line at the end of this section:

NoMMC: Yes

2 Save and close the file

3 The Zetafax configuration program will now launch in non-MMC mode

Status

This has been identified by Equisys as a problem with the software versions given above.

About the author

Posted by Enyenihi of Katharine Gibbs School - New York on March 6, 2003

Need Help with this Issue?

We help people with technology! It's what we do.
Contact or Schedule an Appointment with a location for help!