What to do to share files on the network?

Question

I recently upgraded from win98se to win 2000pro. I previously shared files between two computers with no problem on a simple win network. After the upgrade to win2000, i am being asked for a password to access the file on the network. The window that pops up has a line similar to -(my computer name/C$) and then askes for a password. I do not recall setting up a password for fileshare in the upgrade and I have given full access to the file on the computer where the file is kept. What have I missed? Thanks

Answer

This question was answered on March 27, 2003. Much of the information contained herein may have changed since posting.

You need to share something on Right click on the directory you want to share and choose proeprties Change to the sharing tab and then on the New Share button at the bottom Either make sure Everyone has rights to this share (and Security rights too if you are using NTFS) or ideally you should setup the same username & password on the NT system as you use to logon to the Win98 system.

You could also try manually mapping a drive to \\win2ksystemname\c$ which is a hidden "admninistrative" share of the C drive.

add the share to the W2K desktop computer Do the rest as suggested (i.e use the same username/password to login on the Win98 box or enable Guest account on W2K).

Also

There is no guest account on 98, only on NT, 2k and XP.

In a non Domain worgroup, any connection to a 2k box requires authentication Any unknown users (users coming from Win9x) are treated as "guest" with no password on the account Without this authentication, the users can't even see shares If you don't use username/password to access the 98 box, then the only thing the 2K box will do is try to permit "guest" to access it If the account is locked, then nobody can even get authentication to see the shares in network neighborhood, let alone access them if they could see them.

On the Windows2000 computer - right-click on My Computer, choose Manage, open Local Users and Groups in the left pane, open the users folder, and the right-click on the Guest account in the right pane, and choose properties Make sure "Account is disabled" is UNchecked

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Enyenihi of Katharine Gibbs School - New York on March 27, 2003