Do not display the last user name logged-on

Question

I changed my Win2K User Name (UN) using Computer Management. However, upon reboot the old UN automatically populates the log-on screen. I change it manually and log-on. I want to have that screen populated with the NEW UN. I tried assigning a PW to the new UN, logging out and back in, and then changing PW back to blank. I can log off / on and the new UN populates the log-on screen. But if I reboot the old UN populates that screen. So I tried using MMC and adding the Security Options snap-in and enabling the "Do not display last user name in logon screen", logging off and on and then disabling the above. Again, as long as I log off / on the log-on screen is populated with the new UN. But upon reboot it is populated with the old UN.

I've searched the registry for a text string of the old UN. There appears to be none (at least not related to the OS, but to other SW that leveraged off of the default UN). The UNUSER.DAT file has the OLD UN string in it, but since it is a binary file I can't tell what is going on (I was thinking of editing the file that simply must have that original UN stored).

Any idea how to get the log-on screen populated with the new UN for reboot?

Thanks

Rick Cunnington

Oro Valley, AZ

Answer

This question was answered on March 6, 2004. Much of the information contained herein may have changed since posting.

To Prevent the Last Logged-On User Name from Being Displayed you should do this:

1. Click Start, click Run, type mmc, and then click OK

2. On the Console menu, click Add/Remove Snap-in

3. Click Add

4. Click the Group Policy snap-in, and then click Add

5. Click the target Group Policy object (GPO) The default setting is the local computer Click Browse to select other GPOs that are available on the network Click Finish

6. Click Close, and then click OK

7. Expand the Computer Configuration node, the Windows Settings node, and the Security Settings node

8. Expand the Local Policies node, and then click Security Options

9. In the right pane, double-click the Do not display last user name in logon screen entry

Need Help with this Issue?

We help people with technology! It's what we do.
Schedule an Appointment with a location for help!

Author

Posted by Student of Katharine Gibbs School - New York on March 6, 2004